linux güncelleme komut satırında hata

maho3344

Üye
29 Haz 2021
63
6
36
mrb arkadaslar linux terminale güncelleme komut unda hata yasıyorum sizce nedendir TŞK İYİ GECELER

İLK KOMUT apt-get update

VE İKİNCI KOMUT apt-get upgrade
┌──(root💀kali)-[~]
└─# apt-get upgrade
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
libc-bin : Depends: libc6 (< 2.32) but 2.32-4 is installed
libc-dev-bin : Depends: libc6 (< 2.32) but 2.32-4 is installed
Recommends: manpages-dev but it is not installed
Recommends: libc-devtools (> 2.31) but it is not installed
libc6-amd64 : Depends: libc6 (= 2.31-17) but 2.32-4 is installed
libc6-dev : Depends: libc6 (= 2.31-17) but 2.32-4 is installed
locales : Depends: libc-bin (> 2.32) but 2.31-17 is installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
 

*Crasher

Katılımcı Üye
24 Eyl 2021
259
69
-Vietnam-
Biraz araştırma sonucunda sorunun kaynağını ve çözümünü buldum.Sorunun asıl kaynağı basitçe anlatmak gerekirse bizim sistemimizin server ile el sıkışamaması. Bu hatayı çözmek için lütfen alt kısımdaki işlemleri sırası ile yapınız.

ADIM 1: Dosya yöneticisini açınız ve /etc/apt/sources.list dosyasını açınız ve alt kısımdaki kaynak listesinin tamamını kopyalayınız. apt-get update hatasını çözmek için bu ilk adım.

deb Index of /kali kali-rolling ana katkı ücretsiz olmayan

deb-src Index of /kali kali-haddeleme ana katkısı ücretsiz olmayan

deb Index of /kali sana main bedava olmayan katkı

deb-src Index of /kali sana main bedava olmayan katkı

deb Index of /kali moto main bedava olmayan katkı

deb-src Index of /kali moto main bedava olmayan katkı

Eğer sadece bunu uygulayıp "apt-get update" yaparsanız alt kısımdaki tarzı bir hata alırsınız



ADIM 2: Lütfen şimdi bir komut satırı açınız daha sonra ise alt kısımdaki kodları sırası ile uygulayınız.
gpg key ekleyecegiz:
```gpg --keyserver hkp://keys.gnupg.net --recv-key 7D8D0BF6```
Gpg key’imizi Kontrol edelim
gpg --fingerprint 7D8D0BF6
Eğer çıktınız alt kısımdaki gibiyse işlem tamamdır.

pub rsa4096 2012-03-05 [SC] [expires: 2021-02-03] 44C6 513A 8E4F B3D3 0875 F758 ED44 4FF0 7D8D 0BF6 uid [bilinmiyor] Kali Linux Deposu <[email protected]> sub rsa4096 2012-03-05 [E] [bitiş tarihi: 2021-02-03]


Daha Sonra ise alt kısımdaki kodları uygulayarak güncellemeyi başlatabilirsiniz.
gpg -a --export 7D8D0BF6 | apt-key add -
apt update

ve Sonuç:


Umarım Yardımcı olabilmişimdir.
İyi Forumlar.
 

oBugraReis

Katılımcı Üye
12 Ocak 2021
425
114
VATAN
mrb arkadaslar linux terminale güncelleme komut unda hata yasıyorum sizce nedendir TŞK İYİ GECELER

İLK KOMUT apt-get update

VE İKİNCI KOMUT apt-get upgrade
┌──(root💀kali)-[~]
└─# apt-get upgrade
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
libc-bin : Depends: libc6 (< 2.32) but 2.32-4 is installed
libc-dev-bin : Depends: libc6 (< 2.32) but 2.32-4 is installed
Recommends: manpages-dev but it is not installed
Recommends: libc-devtools (> 2.31) but it is not installed
libc6-amd64 : Depends: libc6 (= 2.31-17) but 2.32-4 is installed
libc6-dev : Depends: libc6 (= 2.31-17) but 2.32-4 is installed
locales : Depends: libc-bin (> 2.32) but 2.31-17 is installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
Yazdığı Gibi apt --fix-broken install Komutunu Deneyebilirsiniz.
 
Üst

Turkhackteam.org internet sitesi 5651 sayılı kanun’un 2. maddesinin 1. fıkrasının m) bendi ile aynı kanunun 5. maddesi kapsamında "Yer Sağlayıcı" konumundadır. İçerikler ön onay olmaksızın tamamen kullanıcılar tarafından oluşturulmaktadır. Turkhackteam.org; Yer sağlayıcı olarak, kullanıcılar tarafından oluşturulan içeriği ya da hukuka aykırı paylaşımı kontrol etmekle ya da araştırmakla yükümlü değildir. Türkhackteam saldırı timleri Türk sitelerine hiçbir zararlı faaliyette bulunmaz. Türkhackteam üyelerinin yaptığı bireysel hack faaliyetlerinden Türkhackteam sorumlu değildir. Sitelerinize Türkhackteam ismi kullanılarak hack faaliyetinde bulunulursa, site-sunucu erişim loglarından bu faaliyeti gerçekleştiren ip adresini tespit edip diğer kanıtlarla birlikte savcılığa suç duyurusunda bulununuz.